WordPress 后台插件更新模块任意目录遍历导致DOS漏洞和IP验证不当漏洞

wordpress教程 2020-08-25

  相信很多使用阿里云服务器的朋友也会收到:

  修复这两个漏洞的最直接的办法就是马上升级到 WordPress 4.6.1 版本即可!

  下面还是简单说说这两个漏洞,以及不升级4.6.1时应该如何手动修复。

  wordpress后台文件/wp-admin/includes/ajax-actions.php中,对代码插件路径的输入参数plugin未进行正确的规范化转义,导致黑客可传入特殊路径,造成拒绝服务。

  wordpress 4.5.4版本:

  打开WordPress后台文件/wp-admin/includes/ajax-actions.php,大概在3077行左右找到以下代码:

  在它的下面添加一行:

  至此,修改保存上传覆盖后即可成功修复WordPress 4.5.4版本的WordPress后台插件更新模块任意目录遍历导致DOS漏洞

  wordpress 4.5.4版本以下:

  WordPress 4.5.4版本以下的,除了要按照WordPress 4.5.4版本的办法修复之外,还需要继续进行以下两个步骤的操作(PS:如果某版本的以下2点中的代码已经跟修复后一样的就不用修改了):

  1、在/wp-admin/includes/ajax-actions.php文件中搜索找以下代码:

  直接修改为:

  在/wp-admin/includes/ajax-actions.php文件中搜索找以下代码:

  直接修改为:

  至此,修改保存上传覆盖后即可成功修复WordPress 4.5.4版本以下的WordPress后台插件更新模块任意目录遍历导致DOS漏洞

  wordpress /wp-includes/http.php文件中的wp_http_validate_url函数对输入IP验证不当,导致黑客可构造类似于012.10.10.10这样的畸形IP绕过验证,进行SSRF

  找到/wp-includes/http.php这个文件,大概在文件465行:

  修改为:

  修改保存上传覆盖后即可成功修复IP验证不当漏洞

  修复后,一定要到阿里云后台“重新验证”或“忽略”漏洞,否则还是会一直发送信息的!

评论 (0)
    Top