判断typecho的版本号

typecho教程 2020-08-25

  前台用

  options->Version(); ?>

  就能输出typecho版本号,而他的格式是这样的

  1.1/17.11.15

  1.1是他的版本,而后面的该版本的日期,所以说即使大家都是1.1,后面日期不一样的话你们的程序代码上就会有区别。

  那么假设你的模板不兼容某个版本的typecho时,为何不做个温馨提示呢?

  

  $tver = substr($this->options->->Version , 0 , 3);

  if($tver>1.0){

  echo ‘该模板可能不兼容大于1.0版本的typecho‘;

  }

  ?>

  也可以根据后面的日期进行判断,总之判断完就能搞各种有趣的事情哈。,就是博主最擅长的事情哈!

  在用可能没有用,没用的话试试下面这个,应该可以:

  Typecho_Widget::widget(‘Widget_Options’)->Version

  或者

  $options = Helper::options();

  $options->version();

  想到这个的原因也是想给自己模板做个判断智能提示下,实现后就写写

评论 (0)
    Top